Create a job always publishes

When creating job orders through the API, it always publishes the jobs. How do you create a job without publishing it? Setting “is_published” doesn’t seem to work.

Thanks!

Hi there,

We don’t currently offer a way to manually specify whether a particular job created in the API should be published or not. What you can do is set the global auto-publish behavior for your site by unchecking the auto-publish setting found in the General Configuration section of your Administration settings, and API should adhere to that. However, I did just find a bug with that setting where the API was often ignoring it, so I have pushed a fix and it should be working as intended later this afternoon.

Thanks for fixing that bug as that should resolve my issue.